2

I wanted to post a link to a comment on our 2015 Moderator Election page, but I can't. Everywhere else, the date/time stamp after the commenter's username is a separate "hotspot" (in the Google Chrome browser under Windows, I just right-click and select Copy link address, so I can paste the link in questions/answers/comments of my own.

I specifically checked this obsolete 2012 Community Moderator Election over on ELU, thinking perhaps there was some "by design" reason why election-related comments might be treated differently. But the links are fine there, so I think my years of unpaid "soak testing" have finally paid off. It may be small, but it's mine own find - and It's a bug!


EDIT: Further to @ColleenV's comment below, upvotes don't work on the comments in the page I linked to either. If this is "by design", I for one fail to see the justification.

| |
  • The 2012 post you linked was just the post in meta pointing to the election site, while the 2015 link goes to the election site. Here's the election site from 2012. I think it's by design because comments also don't have up-votes. Although the ones in the old election do have up-votes, but I can't click on the time stamp. Weird. – ColleenV Aug 28 '15 at 17:06
  • @ColleenV: Well, the development team will be able to say for certain if it is indeed "by design". In which case I'd be interested to know why. I assume the fact that we can't upvote comments on the ELL page is also a mistake, and that both these behaviours stem from essentially the same error on the programming side, so I'll add that to the question. – FumbleFingers Reinstate Monica Aug 28 '15 at 17:18
  • 2
    You can't upvote anything on the election page. I think the idea is that you a lot of comments were becoming "+1" for a particular candidate. – Aaron Brown Aug 28 '15 at 17:35
  • As for the comment-linking thing, you actually can't click on the timestamps on the old election either if you click through to the actual election page and not just the meta question you linked. – Aaron Brown Aug 28 '15 at 17:37
  • @Aaron: I don't have a problem with comments disabled on deleted / locked posts / reviews, which is the situation for those old pages relating to ELU elections. But the 2015 Moderator Election page on ELL is currently active, so that justification doesn't apply. – FumbleFingers Reinstate Monica Aug 28 '15 at 17:52
  • 1
    @Colleen this isn't by-design, it's a bug that was once fixed; but has struck again. – M.A.R. Aug 28 '15 at 18:46
  • 2
    @FumbleFingers I wasn't trying to justify it, just trying to point out that the links don't actually work in old election pages, in contrast to what your OP says. – Aaron Brown Aug 28 '15 at 18:47
  • I don't remember the reasoning, but I do seem to remember this coming up in the TL several months back. I'm pretty sure it's by design, and something that's been changed around a few times (explaining your conflicting links). – WendiKidd Aug 28 '15 at 20:12
  • @WendiKidd: I didn't say anything earlier, but actually you are the very reason I've ended up being frustrated by this issue! I specifically wanted to link to a comment under J.R.'s "pitch" there by a disgruntled user (doubtless you'll recall the context). I realise that if TPTB have decided on a policy that seems "wrong" to me, that'll almost certainly be because I don't understand the issues properly. So I'm prepared for that eventuality, but I don't think we've got there yet! – FumbleFingers Reinstate Monica Aug 28 '15 at 20:31
  • 1
    @FumbleFingers I honestly don't remember exactly why, though I bet it has something to do with unruly users during election. I've put a shout-out to mods from other sites to see if I can wrangle up an answer for you :) – WendiKidd Aug 30 '15 at 7:29
2

There's no "why".

Link to comments in the election says it's ; while you get Election comments have no permalink link later.

It seemed to be fixed; seems like it isn't now. This userscript, the one linked in the highest-voted answer in the latter question, is also unfortunately giving a 404. But SOUP works like a charm for me, Chrome, latest version.


As for why you can't upvote comments in the election page, it's . See this for proof.

There's also Cannot upvote comments under an election nomination in meta.SE. It seems logical to think that when you can't vote on the post, you shouldn't be able to vote up the comments.

I imagine this happens because candidates shouldn't feel discouraged because a "I'd vote for you, definitely!" comment under another candidate's nomination post gets upvoted a lot.

| |
  • If this is an issue, perhaps it would be appropriate to bring it to the attention of Meta SE? Anime's recent election experiences the same issue. – Catija Aug 28 '15 at 18:39
  • @Cat which one? The comment link one? I think so, but I think we'll get the same response: "Try out SOUP!" However, I totally support this bug to be revived in meta.SE. (Don't try a new question though, they'd close it as a dupe of that one) – M.A.R. Aug 28 '15 at 18:41
  • The first part... I don't see how using a third party app is helpful to users. I don't use Chrome and I don't want to add whatever this "SOUP" thing is. – Catija Aug 28 '15 at 18:42
  • Well, you can ask me in chat for the link. ;) And SOUP is available for Firefox too. I think it's the only option we got; I don't believe the team will spend time on this as there's a workaround and it's not a life and death issue. – M.A.R. Aug 28 '15 at 18:44
  • I don't understand this answer. As you say, your first Link to comments in the election says status-completed (it specifically wasn't identified as *by-design). And I can't see anything in see this for proof link to SO revision history (or anywhere else, come to that) explaining why I shouldn't be allowed to link to a comment in the page that's currently of interest to me. – FumbleFingers Reinstate Monica Aug 28 '15 at 20:19
  • 1
    ...on the other hand, I agree with (and will shortly upvote, assuming I'm allowed! :) your comment it's a bug that was once fixed; but has struck again. But that comment seems at odds with your answer. – FumbleFingers Reinstate Monica Aug 28 '15 at 20:22
  • @FumbleFingers I'm trying to indicate that it's a bug that was thought to have been solved but isn't. And "See for proof" is "recent feature changes to SE". It's not again a "why", just a link that says "yeah, you can't up vote election comments". – M.A.R. Aug 28 '15 at 20:23
  • Oh wait, sorry for the confusion. The "proof" says you can't flag election comments. There has been a dispute in some election and people engaged in a flag and up vote war, so that should've been the reason it's removed. I can see but it's traces, in some meta.SE answers. – M.A.R. Aug 28 '15 at 20:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .